System Requirements

If your server meets the following requirements, Easy Forms will run on it.

Note: If you are not sure about your server settings, get in touch with our support team and we will be more than happy to help you.

Server Side Requirements

  • Server Linux/Unix (Recommended), Windows or Mac OS X
  • Web Server Apache (Recommended), Microsoft IIS or any similar web server
  • PHP Version PHP v5.4 or above
  • Database MySQL v5 or higher suggested

Client Side Requirements

  • Web Browser Chrome, Firefox, Safari, Internet Explorer 9+